コンピュータ系/ソフトウェア/pkg_install/download-vulnerability-listが動かなかった場合の対処

2018-04-16 (月) 15:53:00 (1332d)
  • audit-packages は一緒にインストールされる download-vulnerability-list がゲットするpkg-vulnerabilities というファイルを参照しながら実行する.だが,download-vulnerability-listにてftp.NetbSD.orgに入れない(2007/3/15)ので,download-vulnerability-listが動かず,つられてaudit-packagesも動かない.
  • 対処1:どこからか手動で取得してローカルに保存すると,とりあえず動作する
    • 取得先ftp内のだいたいの位置
      • NetBSD/packages/distfiles/
    • 保存先(default)
      • /usr/pkgsrc/distfiles
  • 対処2:http経由でダウンロードするようにする.(こちらが本命)